Benutzeravatar
DerAurich
Neuling

Beiträge:7
Registriert:23. Nov 2015

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 12:58

Guten Tag,

ich habe jetzt das Ambilight für jede HDMI Quelle angeschlossen und funktionieren tut auch alles wunderbar. ABER…

- Ich kann ja über Favoriten die LEDS komplett ausschalten, was auch super funktioniert, nur bleibt eine einzige LED hell. Ist sie Defekt? (Sie ändert mit den anderen LEDs im Betrieb ihre Farbe)
- Das Netzteil gibt ein lauteres Summen von sich… Ich weiß leider nicht wie ich das Problem beheben soll, da ich nicht gerade der geborene Elektriker bin^^

Und jetzt zu meinem größten Problem.
Ich bekomme den Sound vom normalen TV lediglich über den TV und nicht wie die PS4 oder den PI über den AVR…?
Muss ich den TV nochmals an den AVR anschließen? Brauche ich ggf einen Spliiter mit ARC?

Vielen Dank :)

edit: Sehe gerade, dass dieses Problem bekannt ist und es dafür auch schon Lösungsvorschläge gibt.
Zuletzt geändert von DerAurich am 23. Nov 2015, 15:31, insgesamt 1-mal geändert.

b2un0
Moderator

Beiträge:1818
Registriert:16. Nov 2015
Wohnort:Hamburg
Beruf:Softwareentwickler

Probleme bei den LEDs (Laufen tun sie)

23. Nov 2015, 13:20

Für das LED Problem: da gibt es unterschiedliche Lösungsvorschläge, ich arbeite auch gerade an einer Lösung - dazu steh ich auch mit Aki per E-Mail in Kontakt.
Fazit bisher: man darf den hyperiond Dienst einfach nicht abschalten/killen da die LEDs so kein Signal bekommen und halt auf jegliche Spannungspitzen im Stromnetz reagieren. Man muss die LEDs auf "black" schalten, damit sind sie aus

Code: Alles auswählen

$ hyperion-remote --color black

hilft da schon.

Allerdings kann man mit der hyperion-remote nicht den "State" abfragen was gerade aktiv ist was das ganze als schwierig erweist um alle Fälle abzubilden.

Zu dem Netzteil Geräusch, wenn du das aus der Anleitung hast - dann ist dort rechts ein kleines Rädchen wo man mit nem Schraubezieher drehen kann, einfach bei angeschalteten LEDs mal machen, und dann bei ausgeschalteten, damit kann man das justieren. Hatte ich auch und nervte schon ein wenig.
Zuletzt geändert von b2un0 am 23. Nov 2015, 15:48, insgesamt 1-mal geändert.

DerAurich
Neuling

Beiträge:7
Registriert:23. Nov 2015

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 15:34

So dann habe ich mal das Thema geändert ;)

Da sich das Problem mit dem Netzteil ja dann auch gelöst hat, bleibt nur noch das mit der einen LED weiterhin bestehen.
Hast oder hattest du denn das selbe Problem?

Werde für das AVR Problem einen eigenen Thread eröffnen.....

b2un0
Moderator

Beiträge:1818
Registriert:16. Nov 2015
Wohnort:Hamburg
Beruf:Softwareentwickler

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 15:59

Das mit der LED geht leider nur über die Lösung mit dem "color = black".

DerAurich
Neuling

Beiträge:7
Registriert:23. Nov 2015

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 18:25

Kannst du mir noch schnell sagen bei welcher Datei ich es wo einfügen soll? :)

b2un0
Moderator

Beiträge:1818
Registriert:16. Nov 2015
Wohnort:Hamburg
Beruf:Softwareentwickler

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 20:09

Das wird nichts bringen da der "state" nicht abgefragt werden kann ob gerade "black" definiert ist.
Ich nutze noch dazu nicht openElec und die Scripte von Aki sondern meine eigenen direkt in Python geschrieben, nicht in bash.

DerAurich
Neuling

Beiträge:7
Registriert:23. Nov 2015

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 20:57

Dann mal vielleicht noch etwas anderes.
Ich kann doch bestimmt irgendwie einen Schalter (Kippschalter etc..) irgendwo dazwischen anbringen, damit dann ggf. die Stromzufuhr zu den leds gekappt wird.
Ich will halt nur nicht jedes mal den Stecker von den LEDs ziehen müssen, da dieser bei mir doch sehr schwer zu erreichen ist.

b2un0
Moderator

Beiträge:1818
Registriert:16. Nov 2015
Wohnort:Hamburg
Beruf:Softwareentwickler

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 22:44

Klar kannst du da n Schalter zwischen bauen, ist ja auch in der Anleitung vermerkt & hab ich auch :)
Achte nur wo du den zwischen baust, ich würde den im Nachhinein vor das Netzteil setzen, da benötigst du aber einen der auch 230V kann.

Aki
PowerPi-Team

Beiträge:206
Registriert:7. Nov 2015
Wohnort:Oldenburg
Beruf:Grafiker

Eine LED Leuchte geht nicht aus (für jede HDMI Quelle)

23. Nov 2015, 23:32

Jep, wenn man Hyperion ausschaltet, reagieren die LEDs - da sie keine Farbinformationen mehr bekommen - auf den Strom. Dadurch leuchtet bei dir wohl auch die erste LED.

Ja ein Schalter ist gar kein Problem. Ich würde ihn wie, Branko vorgeschlagen hat, vor das Netzteil installieren damit das Netzteil keinen Ton mehr von sich gibt. :mrgreen:

Man braucht dafür dann aber einen 230V Schalter. Zum Beispiel so einen: http://amzn.to/1QEAiNr


Zurück zu „Ambilight - Support“